春天的熊

MyEclipse下Axis2插件的下载和安装

为了用Myeclipse写Webservice~ 搞的我头都大啦~~ 装插件就烦到死~ 下面是我安装axis2的一点心得,和大家分享下~


1.       下载Myeclipse Axis2插件

http://archive.apache.org/dist/ws/axis2/tools/1_4_1/

下载axis2-eclipse-codegen-wizard.zip和axis2-eclipse-service-archiver-wizard.zip

http://labs.xiaonei.com/apache-mirror/ws/axis2/1_5/axis2-1.5-war.zip

 下载axis2-1.5-war.zip

2.解压插件($ECLIPSE_HOME表示你安装的myeclipse主目录)

       将上述两个插件都解压到$ECLIPSE_HOME\eclipse\plugins目录中;

Axis2_Codegen_Wizard_1.3.0 和Axis2_Service_Archiver_1.3.0

3.       在$ECLIPSE_HOME\eclipse\links目录下增加文件axis-eclipse-plugin.link

写入path= $ECLIPSE_HOME\eclipse\plugins (千万不要直接复制!!)

4.       重新启动myeclipse,在file->new->other中即可看到Axis2 Wizards,至此,axis2插件安装成功!!(GXGX)

5.       赶快试下用wsdl文件生成java源文件吧!是不是有错误出现?对~ 事情就是这样发展的。

6.       An error occurred while completing process-java.lang.reflect.InvocationTargetException的错误 。嗯不用急~ 有得解(不过我当初很惨弄了一个晚上)

解决方法如下:
step 1、从AXIS2的LIB库中复制"geronimo-stax-api_1.0_spec-1.0.1.jar"和

 "backport-util-concurrent-3.1.jar"文件到Axis2_Codegen_Wizard_1.3.0的lib目录中,同时修改Axis2_Codegen_Wizard_1.3.0下的plugin.xml文件,在<runtime>中添加

<library name="lib/geronimo-stax-api_1.0_spec-1.0.1.jar">

         <export name="*"/>

</library>

<library name="lib/backport-util-concurrent-3.1.jar">

        <export name="*"/>

</library>

到plugin.xml文件中,保存!

step 2、将 $workspace位置\.metadata\.plugins下目录 Axis2_Codegen_Wizard 删除

step 3、在命令行下切换至$ECLIPSE_HOME目录,然后执行:

eclipse –clear


你再试试~ 应该可以啦!!可以的话就留个言吧~~

PS:AXIS2可以下载axis2-1.4.1-bin.zip(里面有axis2所有的jar)

http://download.huihoo.com/apache/axis2/axis2-1.4.1-bin.zip

 

2012-02-06
/  标签: axis2 plugin
   
评论
热度(1)
  1. 小城,风带香春天的熊 转载了此文字
坚信上帝的延迟,并不是上帝的拒绝。

那些还没有到来的,总会在找寻和尝试中来到。

Here,成长的角落。

Q_Q:317886534